Bootable USB stick on OS X

I need to install Ubuntu on Sony Vaio laptop. So I need to create bootable USB stick for that. My home OS is Mac OS X 10 and today we gonna make bootable USB stick on OS X.

Note: this procedure requires that you create an .img file from the .iso file you download. It will also change the filesystem that is on the USB stick to make it bootable, so backup all data before continuing.

Tip: Drag and drop a file from Finder to Terminal to ‘paste’ the full path without risking typing errors.

1. Download Ubuntu for Desktop.

2. Open the Terminal.

3. Converting the .iso file to .img using the convert option of hdiutil

$ hdiutil convert -format UDRW -o /Data/Downloads/ubuntu.img /Data/Downloads/ubuntu-12.04.5-desktop-i386.iso

4. Insert your flash media and ru:

diskutil list

5. My usb devise is /dev/disk1 we just unmount it  diskutil unmountDisk /dev/disk1 and starting copy process:

$ sudo dd if=/Data/Downloads/ubuntu.img of=/dev/disk1

 

  • Using /dev/rdisk instead of /dev/disk may be faster
  • If you see the error dd: Invalid number ‘1m’, you are using GNU dd. Use the same command but replace bs=1m with bs=1M
  • If you see the error dd: /dev/diskN: Resource busy, make sure the disk is not in use. Start the ‘Disk Utility.app’ and unmount (don’t eject) the drive

6. Run

diskutil eject /dev/disk1

and remove your flash media when the command completes.

All this process looks like:

Bootable USB stick on OS X

Bootable USB stick on OS X

After that I can boot my Sony Vaio from my usb drive 🙂